GetPartCustomDataInteger Method


Fabrication Part Get Part Custom Data Integer Method

Get custom data integer value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetPartCustomDataInteger(
	int customId
)

Parameters

customId Int32
The identifier of the custom data field to get.

Return Value

Int32
Returns the integer of the custom data. If the data is not a number it will return 0.
Exceptions
Exception Condition
ArgumentException The custom data does not exist on the part.
See Also