Duct |
Each duct fitting or duct accessory FamilyInstance has one DuctFittingAndAccessoryPressureDropUIDataItem.

Namespace: Autodesk.Revit.UI.Mechanical
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The DuctFittingAndAccessoryPressureDropUIDataItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DuctFittingAndAccessoryPressureDropUIDataItem |
![]() | GetDuctFittingAndAccessoryData | Gets the fitting data stored in the UI data item. |
![]() | GetEntity | Returns the entity set by UI server. or an invalid entity otherwise. |
![]() | SetEntity | Stores the entity in the UI data item. |

One family instance has one UI data item. The UI data item contains a corresponding DuctFittingAndAccessoryData which is used for initialing the UI settings and an entity which is used for storing the UI settings.