IsValidConceptualConstructionId Method


Conceptual Construction Type Is Valid Conceptual Construction Id Method

Indicates if the ElementId is an id of a ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidConceptualConstructionId(
	Document ccda,
	ElementId constructionTypeId
)

Parameters

ccda Document
The document.
constructionTypeId ElementId
The ElementId of the ConceptualConstructionType.

Return Value

Boolean
Returns true if is an id of a ConceptualConstructionType, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also