External |
This class contains data describing the context related to an external resource load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternalResourceLoadContext type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action. |

Name | Description | |
---|---|---|
![]() | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath. |
![]() | Dispose | Releases all resources used by the ExternalResourceLoadContext |
![]() | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource. |
![]() | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element. |

Note that automatic loads can occur in the context of other operations such as opening a file. During automatic loads, it is therefore recommended that the server only display UI that is critical for the user to see (such as error message).
The loading operation type is Explicit when the user is specifically trying to reload the resource. During explicit loads, it may be desirable to provide more feedback to the user, such as specific feedback that the load operation succeeded.