BuiltInFailures.WallFailures Class


Built In Failures Wall Failures Class

Failures about Wall.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures WallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class WallFailures

The BuiltInFailures WallFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotChangeSubwall Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
Public property Static member CannotChangeTypeOfOldCurtainPanel Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
Public property Static member CannotMaintainKeyReference Can't maintain the position of the Location Line in this Wall.
Public property Static member CannotMirrorWallPanel Cannot mirror wall panels.
Public property Static member CannotRedoFaceBased Faces defining this Element cannot be reacquired.
Public property Static member CannotRedoFaceBasedWarn Faces defining this Element cannot be reacquired.
Public property Static member CannotRedoFaceRoof "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
Public property Static member CannotRedoFaceToposolid "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
Public property Static member CannotSlantStackedWallError Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
Public property Static member CannotSplitJoinHostsInplaceFamilies Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
Public property Static member CannotSplitVerticallyCompoundWall Can't divide Wall's face to assign different materials to a vertically compound Wall.
Public property Static member CannotToSplitWallPanels Unable to split wall panel(s).
Public property Static member CannotUpdateWallPanel Unable to update wall panel.
Public property Static member ChangingWallsweepType This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
Public property Static member ConstrainedToWall Sketch Lines created with Pick Wall must remain parallel to the Wall.
Public property Static member ConstrainedToWallError Sketch Lines created with Pick Wall must remain parallel to the Wall.
Public property Static member ContFootingCannotJoin Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
Public property Static member ContFootingRadiusTooSmall Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
Public property Static member CurtainOrStackedWallDisallowedForCrossSectionType Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
Public property Static member DisallowedPathCurve Cannot create stacked elliptical wall with offsets.
Public property Static member EmbeddedButShouldNotBe Conditions for wall embedding are no longer satisfied.
Public property Static member ExtrudedWallDisallowedForCrossSectionType Edited profiles are not allowed for this wall's cross-section type.
Public property Static member FaceBecameVertical Face defining this non-vertical Wall is vertical.
Public property Static member FaceIsNoGoodForWall Defining face is not suitable for walls.
Public property Static member FaceIsNoLongerVertical Face defining this vertical Wall is no longer vertical.
Public property Static member FaceWallBadType Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
Public property Static member FaceWallComplexType Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
Public property Static member FaceWallFailedToMake Can't make Face Wall shape.
Public property Static member FaceWallMissingFace No picked face found.
Public property Static member FailedConvertWallToPanel Unable to convert wall to panel.
Public property Static member FailedToChangeInstSymbol Failed to change symbol of instance.
Public property Static member FailedToStoreSideFace Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
Public property Static member InvalidBaseConstraintForLevel Base Constraint is invalid for the Level.
Public property Static member InvalidCompoundStructure Invalid compound structure.
Public property Static member InvalidTargetPosition Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
Public property Static member InvalidTargetPositionError Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
Public property Static member InvalidTopConstraintForLevel Top Constraint is invalid for the Level.
Public property Static member LostEditsJoinsRedoFaceBased Previous edits and /or wall joins will not be preserved on this operation.
Public property Static member ParameterChangeNotAffectingGeometry Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
Public property Static member RecursionParameterIgnored Parameter-defined type of curtain panels defined in a circular way and will be ignored.
Public property Static member RemapConstrainLocationLine Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
Public property Static member ShorterThanMinWall Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
Public property Static member ShorterThanMinWallError Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
Public property Static member ShorterThanMinWallFailure Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
Public property Static member ShouldAdjustWallParameters The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
Public property Static member StackedWallNeedsUnjoin A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
Public property Static member SubwallOfStackedWallDeleted This stacked wall will be deleted because a subwall could not be created.
Public property Static member TaperedWallAnglesControlledByType Cannot set angles on a tapered wall which has angles controlled by the type.
Public property Static member TooShortStackedWall Stacked wall instance is too short.
Public property Static member UnableToCreateWallForPanel Unable to create wall for curtain wall panel.
Public property Static member UnableToDeleteWallForPanel Unable to delete curtain panel wall.
Public property Static member UnjoinOnEditWallChange Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
Public property Static member VerticalLayerExtensionFailure Cannot extend layer(s) of the highlighted vertically compound wall.
Public property Static member VerticalLayerExtensionFailureError Cannot extend layer(s) of the highlighted vertically compound wall.
Public property Static member WallCutoutForInsertionFailure Can't cut wall for inserted objects
Public property Static member WallLacksCurve Wall does not have both a curve driver and a curve!!!!
Public property Static member WallNegativeHeight The top of the Wall is lower than the base of the Wall.
Public property Static member WallSettingsChanged Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
Public property Static member WallTypeIncompatibleWithTapered This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.
Top
See Also