VisibleInViewFilter Class


Visible In View Filter Class

A quick filter that passes elements that are most likely visible in the given view.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VisibleInViewFilter : ElementQuickFilter

The VisibleInViewFilter type exposes the following members.

Constructors
Name Description
Public method VisibleInViewFilter(Document, ElementId) Constructs a new instance of a VisibleInViewFilter.
Public method VisibleInViewFilter(Document, ElementId, Boolean) Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory. In some situations (for example, when the element geometry is not yet calculated for the input view) this filter may return true even though the element may not actually be visible when geometry is calculated.
See Also