VisibleInViewFilter Class


Visible In View Filter Class

A quick filter that passes elements that are most likely visible in the given view.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VisibleInViewFilter : ElementQuickFilter

The VisibleInViewFilter type exposes the following members.

Constructors
Name Description
Public method VisibleInViewFilter(Document, ElementId) Constructs a new instance of a VisibleInViewFilter.
Public method VisibleInViewFilter(Document, ElementId, Boolean) Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Top
Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory. In some situations (for example, when the element geometry is not yet calculated for the input view) this filter may return true even though the element may not actually be visible when geometry is calculated.
See Also