TopographyEditScope Class


Topography Edit Scope Class

A TopographyEditScope allows an application to create and maintain an editing session for a TopographySurface.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB.Architecture TopographyEditScope

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TopographyEditScope : EditScope

The TopographyEditScope type exposes the following members.

Constructors
Name Description
Public method TopographyEditScope Instantiates a TopographyEditScope object.
Top
Properties
Name Description
Public property IsActive Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
(Inherited from EditScope )
Public property IsPermitted Tells if the edit scope is permitted to start.
(Inherited from EditScope )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from EditScope )
Top
Methods
Name Description
Public method Cancel Cancels the edit scope.
(Inherited from EditScope )
Public method Commit Finishes the edit scope.
(Inherited from EditScope )
Public method Dispose
(Inherited from EditScope )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Start Starts a topography surface edit mode for an existing TopographySurface element.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Start/end of a TopographyEditScope will start/end a transaction group. After a TopographyEditScope is started, an application can start transactions and edit the topography surface. Individual transactions the application creates inside TopographyEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into TopographyEditScope constructor.
See Also