GetLoopsFromTopBottomFace Method


Exporter IFCUtils Get Loops From Top Bottom Face Method

Gets the curve loop(s) that represent the bottom or top face of the wall, usable to create an extrusion for the wall geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<CurveLoop> GetLoopsFromTopBottomFace(
	ExporterIFC exporterIFC,
	Wall wall
)

Parameters

exporterIFC ExporterIFC
The exporter.
wall Wall
The wall.

Return Value

IList CurveLoop
The curve loops. If the function has failed, this collection will be empty.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function is intended to help determine if a Revit Wall can be exported as an IfcWallStandardCase. The conditions for exporting an IfcWallStandardCase require that the geometry of the wall be described as one profile curve loop extruded in the Z direction, with potential clip planes and openings applied to the base geometry. This function will use either the top or bottom face to determine the boundary curve loop. Regardless of whether the top or bottom face is used, the curve loop will be located on the plane corresponding to the base of the wall.
See Also