Dockable |
Information about a new dockable pane being added to the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The DockablePaneProviderData type exposes the following members.

Name | Description | |
---|---|---|
![]() | DockablePaneProviderData | Initializes a new instance of the DockablePaneProviderData class |

Name | Description | |
---|---|---|
![]() | ContextualHelp | The contextual help associated with the pane. |
![]() | EditorInteraction | Defines the interaction this pane has with the Active Editor when the pane becomes active. |
![]() | FrameworkElement | The Windows Presentation Framework object containing the pane's user interface. |
![]() | FrameworkElementCreator | A creator that will be called for the pane if the FrameworkElement is not set. |
![]() | InitialState | The initial position of the docking pane. |
![]() | VisibleByDefault | Controls the default visibility of the pane upon the first time the pane/plugin is loaded into Revit. |

Name | Description | |
---|---|---|
![]() | GetFrameworkElement | Wrapper function that returns the FrameworkElement for this provider. |