ElementDesignOptionFilter Constructor (ElementId, Boolean)


Element Design Option Filter(Element Id, Boolean) Constructor

Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementDesignOptionFilter(
	ElementId designOptionId,
	bool inverted
)

Parameters

designOptionId ElementId
The design option id to match.
inverted Boolean
True if the filter should match all elements which are not contained within a particular design option.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also