ArrayElementWithoutAssociation Method


Linear Array Array Element Without Association Method

Creates a new linear array from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> ArrayElementWithoutAssociation(
	Document aDoc,
	View dBView,
	ElementId id,
	int count,
	XYZ translationToAnchorMember,
	ArrayAnchorMember anchorMember
)

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id ElementId
The element to array.
count Int32
The number of array members to create including the initial element grouping. Must between 2 and 200 in projects, and between 0 and 200 in families.
translationToAnchorMember XYZ
The translation vector for the array.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

ICollection ElementId
The ids of the elements created during the operation.
Exceptions
Exception Condition
ArgumentException The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Failed to create the linear array.
Remarks
The resulting elements will not be associated with an array element.
See Also