SendToBack Method (Document, View, ElementId)


Detail Element Order Utils Send To Back(Document, View, Element Id) Method

Places the given detail instance behind all detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SendToBack(
	Document document,
	View view,
	ElementId detailElementId
)

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail to send to back.
Exceptions
Exception Condition
ArgumentException The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException A non-optional argument was null
See Also