GetTargetRebarConstraintType Method


Rebar Constraint Get Target Rebar Constraint Type Method

Returns the TargetRebarConstraintType of the handle on the other Rebar Element to which this RebarConstraint is attached. The RebarConstraintType of the RebarConstraint must be 'ToOtherRebar'. Rebar must be Shape Driven Rebar element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TargetRebarConstraintType GetTargetRebarConstraintType()

Return Value

TargetRebarConstraintType
Exceptions
Exception Condition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- Constrained rebar isn't a shape driven rebar element.
See Also