ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)


Element Phase Status Filter(Element Id, Element On Phase Status) Constructor

Constructs a new instance of a file to match elements that have a given phase status on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ElementOnPhaseStatus phaseStatus
)

Parameters

phaseId ElementId
Id of the phase.
phaseStatus ElementOnPhaseStatus
Target status.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also