Revision |
Creates a new alphanumeric revision numbering sequence in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RevisionNumberingSequence CreateAlphanumericSequence(
Document document,
string name,
AlphanumericRevisionSettings settings
)
Parameters
- document Document
- The document of the new revision numbering sequence.
- name String
- The name for the revision numbering sequence.
- settings AlphanumericRevisionSettings
- The alphanumeric settings for the revision numbering sequence.
Return Value
RevisionNumberingSequenceThe newly created revision numbering sequence.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid AlphanumericRevisionSettings. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.