Revit |
The class is used as base class for all event argument classes.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.DB.Events PostEventArgs
Autodesk.Revit.DB.Events PreEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.DB.Events PostEventArgs
Autodesk.Revit.DB.Events PreEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RevitEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. |
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. |

Name | Description | |
---|---|---|