Rebar |
A diameter constraint associated with an arc in a RebarShapeDefinition.

System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeConstraintDiameter type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeConstraintDiameter | Create a diameter constraint. |

Name | Description | |
---|---|---|
![]() | ArcReferenceType | The choice of rule for measuring the diameter. |

Name | Description | |
---|---|---|