Rebar |
A diameter constraint associated with an arc in a RebarShapeDefinition.

System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintDiameter
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeConstraintDiameter type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeConstraintDiameter | Create a diameter constraint. |

Name | Description | |
---|---|---|
![]() | ArcReferenceType | The choice of rule for measuring the diameter. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RebarShapeConstraint ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RebarShapeConstraint ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |