IFCHybridImportOptions Class


IFCHybrid Import Options Class

A set of options to decide on extra AnyCAD processing.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCHybridImportOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class IFCHybridImportOptions : IDisposable

The IFCHybridImportOptions type exposes the following members.

Properties
Name Description
Public property HybridGrids True if we should use AnyCAD to process grids, false otherwise.
Public property HybridLevels True if we should use AnyCAD to process levels, false otherwise.
Public property HybridPropertySets True if we should use AnyCAD to process property sets, false otherwise.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member Create Create a IFCHybridImportOptions from an options string, or null if it isn't hybrid mode.
Public method Dispose Releases all resources used by the IFCHybridImportOptions
Public method Static member ToString(IFCHybridImportOptions) Converts the IFCHybridImportOptions class to a revit.ini-compatible string.
Top
See Also