Family |
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Form NewSweptBlendForm(
bool isSolid,
ReferenceArray path,
ReferenceArrayArray profiles
)
Parameters
- isSolid Boolean
- Indicates if the Form is Solid or Void.
- path ReferenceArray
- The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there's more than one profile, the path should be a single curve. It's required to reference existing geometry.
- profiles ReferenceArrayArray
- The profile set of the newly created swept blend. Each profile should consist of only one curve loop. Each profile must be in a plane that intersects with the path and is perpendicular to the path at the point of intersection.
Return Value
FormIf creation was successful new form is returned.