Fabrication |
The event arguments used by the FabricationPartBrowserChangedEventArgs event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.UI.Events FabricationPartBrowserChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.UI.Events FabricationPartBrowserChangedEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The FabricationPartBrowserChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RevitAPIEventArgs ) |
![]() | NumberOfSolutions | The number of active solutions in routing solution mode. |
![]() | Operation | The operation associated with this event |
![]() | ServiceId | The identifier for the fabrication service. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RevitAPIEventArgs ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAllSolutionsPartsTypeCounts | Returns the total fabrication part type usage count in all routing solutions. |
![]() | GetCurrentSolutionPartTypeIds | Returns set of fabrication part types that are used in the currently selected solution. |
![]() | GetFabricationPartTypeIds | Returns set of fabrication part types in use in the routing solution mode. |
![]() | GetFilteredSolutionsPartsTypeCounts | Returns the active fabrication part type usage count in fitlered routing solutions. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetRequiredFabricationPartTypeIds | Returns set of required fabrication part types in use in routing solution mode. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |