Fabrication |
The event arguments used by the FabricationPartBrowserChangedEventArgs event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.UI.Events FabricationPartBrowserChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.UI.Events FabricationPartBrowserChangedEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The FabricationPartBrowserChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | NumberOfSolutions | The number of active solutions in routing solution mode. |
![]() | Operation | The operation associated with this event |
![]() | ServiceId | The identifier for the fabrication service. |

Name | Description | |
---|---|---|
![]() | GetAllSolutionsPartsTypeCounts | Returns the total fabrication part type usage count in all routing solutions. |
![]() | GetCurrentSolutionPartTypeIds | Returns set of fabrication part types that are used in the currently selected solution. |
![]() | GetFabricationPartTypeIds | Returns set of fabrication part types in use in the routing solution mode. |
![]() | GetFilteredSolutionsPartsTypeCounts | Returns the active fabrication part type usage count in fitlered routing solutions. |
![]() | GetRequiredFabricationPartTypeIds | Returns set of required fabrication part types in use in routing solution mode. |