Gradient Class


Gradient Class

A static class that provides access to the property names that appear in the Gradient visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Gradient

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Gradient

The Gradient type exposes the following members.

Properties
Name Description
Public property Static member GradientColor The property labeled "Color" from the "Gradient" schema.
Public property Static member GradientInterpolation The property labeled "Interpolation" from the "Gradient" schema.
Public property Static member GradientNoise The property labeled "Noise Type" from the "Gradient" schema.
Public property Static member GradientNoiseAmount The property labeled "Amount" from the "Gradient" schema.
Public property Static member GradientNoiseHigh The property labeled "High" from the "Gradient" schema.
Public property Static member GradientNoiseLevels The property labeled "Levels" from the "Gradient" schema.
Public property Static member GradientNoiseLow The property labeled "Low" from the "Gradient" schema.
Public property Static member GradientNoisePhase The property labeled "Phase" from the "Gradient" schema.
Public property Static member GradientNoiseSize The property labeled "Size" from the "Gradient" schema.
Public property Static member GradientNoiseSmooth The property labeled "Smooth" from the "Gradient" schema.
Public property Static member GradientPosition The property labeled "Position" from the "Gradient" schema.
Public property Static member GradientType The property labeled "Gradient Type" from the "Gradient" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Gradient" schema.
Public property Static member TextureOffsetLock The property labeled "Offset Lock" from the "Gradient" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Gradient" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Gradient" schema.
Public property Static member TextureRealWorldScaleX The property labeled "Size X" from the "Gradient" schema.
Public property Static member TextureRealWorldScaleY The property labeled "Size Y" from the "Gradient" schema.
Public property Static member TextureScaleLock The property labeled "Scale Lock" from the "Gradient" schema.
Public property Static member TextureURepeat The property labeled "U Repeat" from the "Gradient" schema.
Public property Static member TextureVRepeat The property labeled "V Repeat" from the "Gradient" schema.
Public property Static member TextureWAngle The property labeled "Angle" from the "Gradient" schema.
Top
See Also