AddExternallyTaggedGeometry Method


Direct Shape Add Externally Tagged Geometry Method

Adds the externally tagged geometry object to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddExternallyTaggedGeometry(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShape.
Exceptions
Exception Condition
ArgumentException The input shape does not satisfy DirectShape validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShape.
ArgumentNullException A non-optional argument was null
See Also