LinkConversionData Class


Link Conversion Data Class

This class contains the information necessary to re-create a Revit document from an external source.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LinkConversionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinkConversionData : IDisposable

The LinkConversionData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Path The path to the source data used to generate the model.
Public property ServerId The service responsible for converting the data into a Revit file.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LinkConversionData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetOptions Extra information used during the creation of the Revit document.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also