CurveUV Class


Curve UV Class

A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CurveUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveUV : IDisposable

The CurveUV type exposes the following members.

Properties
Name Description
Public property IsBound Describes whether the parameter of the curve is restricted to a particular interval.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method As3DCurveInXYPlane Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public method ComputeDerivatives Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
Public method Static member Create Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public method Dispose Releases all resources used by the CurveUV
Public method Evaluate Evaluates and returns the point at the specified parameter along the curve.
Public method GetEndParameter Gets the raw parameter value at the start or end of this curve.
Public method Transform Transform this CurveUV by the given 2D affine transform if possible.
Top
Remarks
Revit does not have a class to represent 2D curves explicitly.
See Also