BuiltInFailures.FormFailures Class


Built In Failures Form Failures Class

Failures about Form.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures FormFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class FormFailures

The BuiltInFailures FormFailures type exposes the following members.

Properties
Name Description
Public property Static member AddProfileFailure Failed to Add Profile
Public property Static member DissolveNoValidInputs No form elements selected to dissolve.
Public property Static member DissolveUnableToDissolveForm Unable to dissolve form element.
Public property Static member FormCreationInvalidGeomCombination Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
Public property Static member FormElemRegenFailure Unable to create form element
Public property Static member FormElemRegenFailureError Unable to create form element
Public property Static member FormElemRegenSelfIntersection Unable to create form element: self-intersecting or singular geometry would result.
Public property Static member FormElemRegenSelfIntersectionReorderProfiles This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
Public property Static member FormElemRegenSelfIntersectionResetConnections This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
Public property Static member OpenProfileMultiSegmentSweepsNotSupported An open profile cannot be swept along a multi-segment path.
Public property Static member VoidFormsNotUsed Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.
Top
See Also