AddField Method (SchedulableField)


Schedule Definition Add Field(Schedulable Field) Method

Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ScheduleField AddField(
	SchedulableField schedulableField
)

Parameters

schedulableField SchedulableField
A SchedulableField object representing the field.

Return Value

ScheduleField
The new field.
Exceptions
Exception Condition
ArgumentException The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
See Also