BIMExport |
The base class for options used to export using ATF.

System Object
Autodesk.Revit.DB BIMExportOptions
Autodesk.Revit.DB OBJExportOptions
Autodesk.Revit.DB STEPExportOptions
Autodesk.Revit.DB STLExportOptions
Autodesk.Revit.DB BIMExportOptions
Autodesk.Revit.DB OBJExportOptions
Autodesk.Revit.DB STEPExportOptions
Autodesk.Revit.DB STLExportOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BIMExportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ViewId | The element id of the 3D view to export. InvalidElementId by default. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BIMExportOptions |