Create Method


Phase Filter Create Method

Creates a new phase filter with default status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PhaseFilter Create(
	Document document,
	string name
)

Parameters

document Document
The document.
name String
The name.

Return Value

PhaseFilter
The newly created phase filter.
Exceptions
Exception Condition
ArgumentException name is already in use.
ArgumentNullException A non-optional argument was null
Remarks
The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing, Demolished and Temporary statuses.
See Also