StringParameterValue Class


String Parameter Value Class

A class that holds a String value of a parameter element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterValue
Autodesk.Revit.DB StringParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StringParameterValue : ParameterValue

The StringParameterValue type exposes the following members.

Constructors
Name Description
Public method StringParameterValue Default constructor
Public method StringParameterValue(String) Value constructor
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ParameterValue )
Public property Value The stored value
Top
Methods
Name Description
Public method Copy Makes an identical copy of the given parameter value.
(Inherited from ParameterValue )
Public method Dispose
(Inherited from ParameterValue )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEqual Tests equality with another instance of the same class.
(Inherited from ParameterValue )
Public method IsSameType Tests another instance is of the same value type.
(Inherited from ParameterValue )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also