Parameter Property (BuiltInParameter)


Element Parameter(Built In Parameter) Property

Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Parameter this[
	BuiltInParameter parameterId
] { get; }

Parameters

parameterId BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.
See Also