AssignedFlow Property


Connector Assigned Flow Property

The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double AssignedFlow { get; set; }

Property Value

Double
Exceptions
Exception Condition
InvalidOperationException Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
ArgumentException Thrown when set an invalid value.
InvalidOperationException Thrown on failure to get or set assigned flow.
Remarks
Assigned flow may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also