IsUniqueName Method


Global Parameters Manager Is Unique Name Method

Tests whether a name is unique among existing global parameters of a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsUniqueName(
	Document document,
	string name
)

Parameters

document Document
Document in which a new parameter is to be added.
name String
A name of a parameter being added.

Return Value

Boolean
True if the given %name% does not exist yet among existing global parameters nof the document; False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Typically, this method is used before a new global parameters is created, for all global parameters must have their names unique in the scope of a document.
See Also