BuiltInFailures.PipingFailures Class


Built In Failures Piping Failures Class

Failures about Pipes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures PipingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class PipingFailures

The BuiltInFailures PipingFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotCreateGeometryForPipe Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
Public property Static member CircularLoopInPipeSizing Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
Public property Static member DuctPipeModified The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
Public property Static member DuctPipeSizeMismatch The duct/pipe size is invalid for the service definition
Public property Static member FabFittingFailed The Fabrication Fitting was invalid
Public property Static member InvalidPipeSize Pipe Size Table "[File Name]" is missing or invalid.
Public property Static member MaxPipeSizeReached Maximum pipe size diameter reached during sizing
Public property Static member PartNotFoundDueToNoPipeConnectedError "In order to find a matching part, the fitting has to be connected to a pipe."
Public property Static member PartNotFoundDueToNoPipeConnectedWarning "In order to find a matching part, the fitting has to be connected to a pipe."
Public property Static member PartNotFoundInRoutingPreferenceError "%1s is not found. Please review the routing preference of %2s."
Public property Static member PartNotFoundInRoutingPreferenceWarning "%1s is not found. Please review the routing preference of %2s."
Top
See Also