CurveIntersectResultOption Enumeration


Curve Intersect Result Option Enumeration

Specifies how much information will be computed and returned when calculating intersection of Curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public enum CurveIntersectResultOption
Members
Member name Value Description
Detailed 1 Return overlap points and intervals, in addition to the intersection's classification. Note: selecting this option may cause additional calculations to be performed when determining the curve intersection.
Simple 0 Only return the SetComparisonResult classifying the type of intersection (or lack thereof).
See Also