MacroModuleIterator Class


Macro Module Iterator Class

An iterator to the Macros in a MacroModule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Macros MacroModuleIterator

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MacroModuleIterator : IEnumerator<Macro>

The MacroModuleIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MacroModuleIterator
Public method GetCurrent Returns the current Macro.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the iterator to the next item.
Public method Reset Resets the iterator to the initial state.
Top
See Also