VertexBuffer Class


Vertex Buffer Class

A buffer that stores vertex data for rendering.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D VertexBuffer

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexBuffer : IDisposable

The VertexBuffer type exposes the following members.

Constructors
Name Description
Public method VertexBuffer Constructs the vertex buffer with the given capacity, measured in floats.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the VertexBuffer
Public method GetMappedHandle Gets a handle to the buffer's memory that has been mapped. Writing data to the buffer using the handle is an alternative to using stream objects.
Public method GetVertexStreamPosition Gets a stream that can be used to write vertices of type VertexPosition into the buffer.
Public method GetVertexStreamPositionColored Gets a stream that can be used to write vertices of type VertexPositionColored into the buffer.
Public method GetVertexStreamPositionNormal Gets a stream that can be used to write vertices of type VertexPositionNormal into the buffer.
Public method GetVertexStreamPositionNormalColored Gets a stream that can be used to write vertices of type VertexPositionNormalColored into the buffer.
Public method IsValid Tests whether the buffer is valid for rendering.
Public method Map Maps a portion of the buffer into memory, so that vertex data can be written into it. (see VertexStream ).
Public method Unmap Unmaps the buffer, so that it can be used for rendering.
Top
See Also