ToWorksets Method


Filtered Workset Collector To Worksets Method

Returns the complete set of worksets that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Workset> ToWorksets()

Return Value

IList Workset
The complete array of worksets.
Exceptions
Exception Condition
InvalidOperationException The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also