SetComparisonResult Enumeration


Set Comparison Result Enumeration

An enumerated type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public enum SetComparisonResult
Members
Member name Value Description
BothEmpty 3 Both sets are empty.
Disjoint 4 Both sets are not empty and don't overlap.
Equal 64 Two nonempty sets are equal.
LeftEmpty 1 The left set is empty and the right set is not.
Overlap 8 The overlap of two sets is not empty and is a strict subset of both.
RightEmpty 2 The right set is empty and the left set is not.
Subset 16 Both sets are not empty and the left set is strict subset of the right.
Superset 32 Both sets are not empty and the left set is a strict superset of the right.
See Also