Group
|
This class contains constants identifying parameter groups.

System
Object
Autodesk.Revit.DB GroupTypeId
Autodesk.Revit.DB GroupTypeId
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The GroupTypeId type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() |
AdskModelProperties | Model Properties. |
![]() ![]() |
AlternateUnits | Alternate Units. |
![]() ![]() |
AnalysisResults | Analysis Results. |
![]() ![]() |
AnalyticalAlignment | Analytical Alignment. |
![]() ![]() |
AnalyticalModel | Analytical Model. |
![]() ![]() |
AnalyticalProperties | Analytical Properties. |
![]() ![]() |
Area | Area. |
![]() ![]() |
ConceptualEnergyData | Conceptual Energy Data. |
![]() ![]() |
ConceptualEnergyDataBuildingServices | Energy Model - Building Services. |
![]() ![]() |
Constraints | Constraints. |
![]() ![]() |
Construction | Construction. |
![]() ![]() |
ContinuousrailBeginBottomExtension | Extension (Beginning/Bottom). |
![]() ![]() |
ContinuousrailEndTopExtension | Extension (End/Top). |
![]() ![]() |
CouplerArray | Set. |
![]() ![]() |
CurtainGrid | Grid. |
![]() ![]() |
CurtainGridHoriz | Horizontal Grid. |
![]() ![]() |
CurtainGridn1 | Grid 1. |
![]() ![]() |
CurtainGridn2 | Grid 2. |
![]() ![]() |
CurtainGridU | U Grid. |
![]() ![]() |
CurtainGridV | V Grid. |
![]() ![]() |
CurtainGridVert | Vertical Grid. |
![]() ![]() |
CurtainMullionHoriz | Horizontal Mullions. |
![]() ![]() |
CurtainMullionn1 | Grid 1 Mullions. |
![]() ![]() |
CurtainMullionn2 | Grid 2 Mullions. |
![]() ![]() |
CurtainMullionVert | Vertical Mullions. |
![]() ![]() |
Data | Data. |
![]() ![]() |
Display | Display. |
![]() ![]() |
DivisionGeometry | Division Geometry. |
![]() ![]() |
Electrical | Electrical. |
![]() ![]() |
ElectricalAnalysis | Electrical Analysis. |
![]() ![]() |
ElectricalCircuiting | Electrical - Circuiting. |
![]() ![]() |
ElectricalEngineering | Electrical Engineering. |
![]() ![]() |
ElectricalLighting | Electrical - Lighting. |
![]() ![]() |
ElectricalLoads | Electrical - Loads. |
![]() ![]() |
EnergyAnalysis | Energy Analysis. |
![]() ![]() |
EnergyAnalysisAdvanced | Advanced. |
![]() ![]() |
EnergyAnalysisBldgConsMtlThermalProps | Material Thermal Properties. |
![]() ![]() |
EnergyAnalysisBuildingData | Building Data. |
![]() ![]() |
EnergyAnalysisConceptualModel | Energy Analytical Model. |
![]() ![]() |
EnergyAnalysisDetailedAndConceptualModels | Essential. |
![]() ![]() |
EnergyAnalysisDetailedModel | Detailed Model. |
![]() ![]() |
EnergyAnalysisRoomSpaceData | Room/Space Data. |
![]() ![]() |
FabricationProductData | Fabrication Product Data. |
![]() ![]() |
FireProtection | Fire Protection. |
![]() ![]() |
Fitting | Fittings. |
![]() ![]() |
Flexible | Adaptive Component. |
![]() ![]() |
Forces | Forces. |
![]() ![]() |
General | General. |
![]() ![]() |
GeoLocation | Geolocation. |
![]() ![]() |
Geometry | Geometry. |
![]() ![]() |
GeometryPositioning | Geometric Position. |
![]() ![]() |
Graphics | Graphics. |
![]() ![]() |
GreenBuilding | Green Building Properties. |
![]() ![]() |
IdentityData | Identity Data. |
![]() ![]() |
Ifc | IFC Parameters. |
![]() ![]() |
Insulation | Insulation. |
![]() ![]() |
Length | Length. |
![]() ![]() |
LifeSafety | Life Safety. |
![]() ![]() |
LightPhotometrics | Photometrics. |
![]() ![]() |
Lining | Lining. |
![]() ![]() |
Materials | Materials and Finishes. |
![]() ![]() |
Mechanical | Mechanical. |
![]() ![]() |
MechanicalAirflow | Mechanical - Flow. |
![]() ![]() |
MechanicalLoads | Mechanical - Loads. |
![]() ![]() |
Moments | Moments. |
![]() ![]() |
Nodes | Nodes. |
![]() ![]() |
OverallLegend | Overall Legend. |
![]() ![]() |
Pattern | Pattern. |
![]() ![]() |
PatternApplication | Pattern Application. |
![]() ![]() |
Phasing | Phasing. |
![]() ![]() |
Plumbing | Plumbing. |
![]() ![]() |
PrimaryEnd | Primary End. |
![]() ![]() |
PrimaryUnits | Primary Units. |
![]() ![]() |
Profile | Profile. |
![]() ![]() |
Profilen1 | Profile 1. |
![]() ![]() |
Profilen2 | Profile 2. |
![]() ![]() |
RailingSystemFamilyHandrails | Handrail 1. |
![]() ![]() |
RailingSystemFamilySegmentPattern | Segment Pattern (default). |
![]() ![]() |
RailingSystemFamilyTopRail | Top Rail. |
![]() ![]() |
RailingSystemSecondaryFamilyHandrails | Handrail 2. |
![]() ![]() |
RailingSystemSegmentPatternRemainder | Pattern Remainder. |
![]() ![]() |
RailingSystemSegmentPatternRepeat | Pattern Repeat. |
![]() ![]() |
RailingSystemSegmentPosts | Posts. |
![]() ![]() |
RailingSystemSegmentUGrid | U Grid. |
![]() ![]() |
RailingSystemSegmentVGrid | V Grid. |
![]() ![]() |
RebarArray | Rebar Set. |
![]() ![]() |
RebarSystemLayers | Layers. |
![]() ![]() |
Reference | Reference. |
![]() ![]() |
ReleasesMemberForces | Releases / Member Forces. |
![]() ![]() |
RotationAbout | Rotation about. |
![]() ![]() |
RouteAnalysis | Route Analysis. |
![]() ![]() |
SecondaryEnd | Secondary End. |
![]() ![]() |
SegmentsFittings | Segments and Fittings. |
![]() ![]() |
SlabShapeEdit | Slab Shape Edit. |
![]() ![]() |
SplitProfileDimensions | Dimensions (linear units or % of thickness). |
![]() ![]() |
StairRisers | Risers. |
![]() ![]() |
StairsCalculatorRules | Calculation Rules. |
![]() ![]() |
StairsOpenEndConnection | End Connection. |
![]() ![]() |
StairsSupports | Supports. |
![]() ![]() |
StairsTreadsRisers | Threads/Risers. |
![]() ![]() |
StairStringers | Stringers. |
![]() ![]() |
StairsWinders | Winders. |
![]() ![]() |
StairTreads | Treads. |
![]() ![]() |
Structural | Structural. |
![]() ![]() |
StructuralAnalysis | Structural Analysis. |
![]() ![]() |
StructuralSectionDimensions | Structural Section Dimensions. |
![]() ![]() |
StructuralSectionGeometry | Structural Section Geometry. |
![]() ![]() |
Support | Supports. |
![]() ![]() |
SystemtypeRisedrop | Rise / Drop. |
![]() ![]() |
Termination | Terminations. |
![]() ![]() |
Text | Text. |
![]() ![]() |
Title | Title Text. |
![]() ![]() |
ToposolidSubdivision | Sub-division. |
![]() ![]() |
TranslationIn | Translation in. |
![]() ![]() |
TrussFamilyBottomChord | Bottom Chords. |
![]() ![]() |
TrussFamilyDiagWeb | Diagonal Webs. |
![]() ![]() |
TrussFamilyTopChord | Top Chords. |
![]() ![]() |
TrussFamilyVertWeb | Vertical Webs. |
![]() ![]() |
Underlay | Underlay. |
![]() ![]() |
ViewCamera | Camera. |
![]() ![]() |
ViewExtents | Extents. |
![]() ![]() |
ViewPositioning | View to Sheet Positioning. |
![]() ![]() |
Visibility | Visibility. |
![]() ![]() |
Visualization | Visualization. |
![]() ![]() |
WallCrossSectionDefinition | Cross-Section Definition. |