GetModelUpdatesStatus Method


Worksharing Utils Get Model Updates Status Method

Gets the status of a single element in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ModelUpdatesStatus GetModelUpdatesStatus(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document containing the element.
elementId ElementId
The id of the element.

Return Value

ModelUpdatesStatus
The status of the element in the local session versus the central model.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks

This method returns a locally cached value which may not be up to date with the current state of the element in the central. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. Also, the return value may not be dependable in the middle of a local transaction. See the remarks on WorksharingUtils for more details.

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element will not be expanded.

See Also