IsValidPlaneReference Method


Point On Plane Is Valid Plane Reference Method

Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidPlaneReference(
	Document doc,
	Reference planeReference
)

Parameters

doc Document
planeReference Reference

Return Value

Boolean
Remarks
Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane ; the Reference property of ReferencePlane .
See Also