GetBoundary Method


Energy Analysis Space Get Boundary Method

Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces, if in rooms and spaces mode. In other modes, returns no polyloops.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<Polyloop> GetBoundary()

Return Value

IList Polyloop
The collection of polygons that form the 2D boundary.
See Also