FabricationPartFitResult Enumeration


Fabrication Part Fit Result Enumeration

Fabrication part stretch/fill result.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum FabricationPartFitResult
Members
Member name Value Description
BadDimensions 4 Failed due to the required dimension values not being valid to fabricate.
DimensionLocked 3 Failed due to not being able to change a locked or product listed dimension.
IncompatibleConnection 7 Failed due to connectors being incompatible and no couplings found to resolve it.
IncompatibleGeometry 1 Failed because the part didn't have the dimensions required to meet the geometry requirements.
MisalignedEnds 2 Failed due to misalignment of fitting ends.
OffsetRequired 8 Failed due to additional offset dimensions or fittings being required that weren't available.
ShapeMismatch 5 Failed due to shape mismatch of fitting ends.
SizeMismatch 6 Failed due to size mismatch of fitting ends.
Success 0 Operation was successful.
Unsupported 255 Failed due to unsupported routing path.
See Also