BuildingOperatingSchedule Property


Energy Data Settings Building Operating Schedule Property

The operating schedule of the building used for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; }

Property Value

gbXMLBuildingOperatingSchedule
Exceptions
Exception Condition
ArgumentException When setting this property: The building operating schedule does not fall within an appropriate range.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also