AddInstanceVoidCut Method


Instance Void Cut Utils Add Instance Void Cut Method

Add a cut to an element using the unattached voids inside a cutting instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void AddInstanceVoidCut(
	Document document,
	Element element,
	Element cuttingInstance
)

Parameters

document Document
The document containing the two elements
element Element
The element to be cut
cuttingInstance Element
The cutting family instance
Exceptions
Exception Condition
ArgumentException The element cannot be cut with a void instance. -or- The element is not a family instance with an unattached void that can cut.
ArgumentNullException A non-optional argument was null
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
InvalidOperationException Failed to cut element with the instances
See Also