SymbolGeometryId Class


Symbol Geometry Id Class

This class is used to identify a piece of geometry managed by a symbol element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SymbolGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SymbolGeometryId : IDisposable

The SymbolGeometryId type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SymbolId The id of the symbol which contains the shared geometry.
Top
Methods
Name Description
Public method AsUniqueIdentifier Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public method Dispose Releases all resources used by the SymbolGeometryId
Top
Remarks
This class can be used to compare if two instances points to the same piece of geometry managed by a symbol element. The string returned by AsIdentifier can be used to achieve this.
See Also