Light |
This class represents a Light element in a model-exporting process.

System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ContentNode
Autodesk.Revit.DB LightNode
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ContentNode
Autodesk.Revit.DB LightNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The LightNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

See also: [!:Autodesk::Revit::DB::IExportContext::OnLight] .