AddExternallyTaggedGeometry Method


Direct Shape Type Add Externally Tagged Geometry Method

Adds the externally tagged geometry object to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddExternallyTaggedGeometry(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShapeType.
Exceptions
Exception Condition
ArgumentException The input shape does not satisfy DirectShapeType validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShapeType.
ArgumentNullException A non-optional argument was null
See Also