CutFailureReason Enumeration


Cut Failure Reason Enumeration

The reason why a solid-solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum CutFailureReason
Members
Member name Value Description
CutAllowed 0 Yes, the cutting element can add a cut to the target element.
CutAlreadyExists 1 The cutting element has already cut the target element.
CutNotAppropriateForElements 3 The cut is not appropriate for the two elements.
OppositeCutExists 2 The target element has already cut the cutting element.
See Also