Family |
Add a new family parameter with a given name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyParameter AddParameter(
string parameterName,
ForgeTypeId groupTypeId,
ForgeTypeId specTypeId,
bool isInstance
)
Parameters
- parameterName String
- The name of the new family parameter.
- groupTypeId ForgeTypeId
- The identifier of the new family parameter's parameter group.
- specTypeId ForgeTypeId
- The type of new family parameter.
- isInstance Boolean
- Indicates if the new family parameter is instance or type.
Return Value
FamilyParameterIf creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"parameterName"-is . |
ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"specTypeId" is an invalid type, or the input parameter group cannot be assigned to the new parameter. |
InvalidOperationException | Thrown when the family parameter creation failed. Or trying to add an instance parameter of image type. |

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type. To add a parameter of family type use the AddParameter overload that accepts a category instead.